WordPress 5.6.2 Update is Largely Successful

WordPress 5.6.2 Update is Largely Successful

WordPress rolled out a bug fix update, version 5.6.2. Aside from an issue affecting Ultimate Addons for Gutenberg plugin, the update is largely successful, publishers are encouraged to update.

WordPress 5.6.2

WP 5.6.2 is called a Maintenance Update. A maintenance update is one that is meant to fix bugs introduced by a previous update. Because a maintenance update fixes problems, it is generally recommended that publishers update their WordPress to the latest version.

Bug Fixes

The latest update fixes a problem introduced with version 5.6.1. That issue was called the “Leave site? Changes you made may not be saved” bug. What happens is that on certain pages in the Admin backend, WordPress would spawn a warning that changes that were made would not be saved.

Advertisement

Continue Reading Below

The initial report of the bug described it like this:

“We use custom taxonomies extensively, and as of 5.6.1 today, every custom taxonomy page now prompts with “Leave site? Changes you made may not be saved.” This has never happened before for custom taxonomies and is now quickly getting really annoying.”

This caused considerable confusion in the WordPress publishing community as many were unsure of why they were receiving the warning message.

WordPress publishers are encouraged to update to version 5.6.2 because it contains a bug fix and there are no widespread reports of issues.

Ultimate Addons for Gutenberg Bug

The only reported bug has to do with a third party plugin called Ultimate Addons for Gutenberg by Brainstorm Force.

According to a report on the WordPress support forums the bug causes a display issue. In terms of bugs this is a relatively minor issue. The issue is apparently a bug with the plugin and not with WordPress.

Advertisement

Continue Reading Below

Publishers using the Ultimate Addons for Gutenberg plugin who are experiencing display anomalies are encouraged to file a support ticket at WP Astra, the publishers of the plugin.

The person reporting the issue shared this description of the problem:

“I’ve done some testing and was able to pin down the problem. It’s a plugin, specifically Ultimate Addons for Gutenberg. And more specifically, it only happens when using a Post Carousel.

Note: There could be more triggers for the problem, but that’s the one affecting me right now.

When I disable that plugin, the problem goes away. Sadly, I can’t just disable it because I use some of this blocks for a lot of content.

PD: Oh, and if you still need the info, the theme I’m using is Astra

PD2: I tried twenty twenty-one and twenty nineteen and the problem is not there. Seems to be linked to Astra and Ultimate Addons for Gutenberg working together.”

The bug appears to be a fairly inconsequential issue, one that affects a relatively low number of WordPress publishers.

WordPress 5.6.2 appears to be a safe update. Publishers are encouraged to update their WordPress installations.

Citation

Read the official WordPress announcement:

WordPress 5.6.2 Maintenance Release

local_offerevent_note February 23, 2021

account_box matheo

Leave a Reply

Your email address will not be published. Required fields are marked *